dcsimg
www.webdeveloper.com
Results 1 to 6 of 6

Thread: I can't get one of my DIV columns to move to the right?? Any ideas.. It's the text na

Hybrid View

  1. #1
    Join Date
    Feb 2012
    Location
    Sacramento, CA
    Posts
    64

    I can't get one of my DIV columns to move to the right?? Any ideas.. It's the text na

    It's the text navigation panel on top that I'm having trouble moving around.
    It's just a little bit too much to the left..



    http://sealteamrealty.com/inc/index.php?page=home

  2. #2
    Join Date
    Jan 2012
    Posts
    31
    You have the "nav_bar" floated left. You should wrap the "nav_main2" and "container_2" div's inside another div and have the new wrapper div floated left also. This will make is so you don't have to try and move those two right with positioning or margins.

  3. #3
    Join Date
    Feb 2012
    Location
    Sacramento, CA
    Posts
    64

    Thanks,

    But the strangest thing happened after that fix.. On the pages where I actually have some written content (specifically the Property Management page and the Gallery Pages) the whole tops links and content container FALL below my image button links..?? I've tried changing various attributes like limiting the text width, content box width, etc.. I can't figure it out?

  4. #4
    Join Date
    Feb 2007
    Location
    New York, NY
    Posts
    27

    try % widths

    Do you need all those separate liked style sheets? CSS = cascading. Last linked style sheet (or closest to element) overrides previous ones.

    You have to make your buttons and content narrower to fit side by side in width of window. Remember "box model" and add right + left margins, padding, border to content width.

    Try giving your buttons and content <div>s percentage widths.

  5. #5
    Join Date
    Feb 2012
    Location
    Sacramento, CA
    Posts
    64
    ya still can't figure it out, I'll have to read up on the "box Model"..

  6. #6
    Join Date
    Feb 2007
    Location
    New York, NY
    Posts
    27
    Seems to be fixed now.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles