www.webdeveloper.com
Results 1 to 4 of 4

Thread: [RESOLVED] Toggling ul li items kinda working but need help from pro.

  1. #1
    Join Date
    Nov 2012
    Posts
    3

    resolved [RESOLVED] Toggling ul li items kinda working but need help from pro.

    Hi and thanks for reading. I am a newborn newbie so the code matches. I have two lists - One for "Her" and one for "Him". What's supposed to happen is the user clicks on Her or Him and a list of prices drops down. Then on clicking again, the list goes away. It kinda is working. The trouble I am having is:

    first - the user has to click twice to get the toggle action going,

    and second - when it disappears, the space below is still left. There is no resetting, so there is this giant white space left.


    I imagine my code is all wrong but as it's all I know right now, any pro who can teach me the correct way to do this would be amazingly appreciated. Thank you.

    Here is the page where you can see the semi-action going on: http://waxstudio.businesscatalyst.com/index4.html

    This is using the Zurb Foundation framework so any css is found in app.css

  2. #2
    Join Date
    Feb 2013
    Posts
    46
    Have you checked the error console? There is a timer that continuously has an error....... which may eventually crash the browser..

    It's fwslider on line 313.. There is also an error on fwslider line 54- but the one that keeps repeating is line 313.

    I think part of the problem is you are including jquery 1.9 in <head> but in body you include a lower version of jquery 1.6.3 which will overwrite all of the plugins such as the one erroring (which is in head). Try to consolidate your js libraries then see if the errors go away. I wouldn't try debugging ur script until u get the existing errors removed

  3. #3
    Join Date
    Nov 2012
    Posts
    3
    That was the problem.. I had to remove the duplicate Jquery. Thank you so much for your help!

  4. #4
    Join Date
    Dec 2005
    Location
    FL
    Posts
    7,413
    Link in post #1 doesn't work.

    If thread has been resolved, please mark as so with thread tools.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles