www.webdeveloper.com
Results 1 to 4 of 4

Thread: Colour is changing on its own

  1. #1
    Join Date
    Jan 2013
    Posts
    25

    Colour is changing on its own

    Hi Guys

    Can anyone put me out of my misery lol Been stuck with this for quite a while now

    If you go to the drop down menu (http://www.ccmediaservices.co.uk/) of "your next move" you can see I've been using the opacity function for a nice hover effect. But with my sub menu that drop downs for some reason the font color looks different then the rest of the nav bar and it is unreadable.

    I've inspected it with firebug and can't see any different styles being applied just the correct ones.

    I'm wondering if this has something to do with the background it is rendering on?

    Any feedback greatly appreciated as I've found this tricky

  2. #2
    Join Date
    Aug 2012
    Location
    Canada
    Posts
    56
    It looks like the theme has pretty much screwed up the css. The element looks like it is inheriting a color of #686868 (but it could be anything the way the thing is put together). The cascade has been turned into chaos. There is probably some wayward scripting that is messing up the DOM, and there are a few validation errors in the HTML.

    I suggest you isolate the nav in a page by itself and the start adding in the junk until you see which one is breaking it.

    Cd&

  3. #3
    Join Date
    Jan 2013
    Posts
    25
    Hmm I've never heard of this happening before.

    The them is wordpresses own twenty twelve, I have edited by adding some divs changing the structure and adding some extra colours and images nothing crazy

    The twenty twelve theme is a responsive minimalistic theme intended for people to then modify into there own.

    I'm lost as what to do next

  4. #4
    Join Date
    Jan 2013
    Posts
    25
    Hi

    I've now fixed all the validation errors the html on the page itself is now valid and there are just 5 errors on the css validation but that is also true of the standard wordpress twenty twelve theme. Basically there is no errors on my behalf. There are also a run of rel errors but that is to do with the royal slider plugin purchased not any code I have written.

    Still the issue remains. Anyone got any ideas with this one its a tough one!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles