www.webdeveloper.com
Results 1 to 4 of 4

Thread: [RESOLVED] Weird Browser Scaling Issue

  1. #1
    Join Date
    Nov 2011
    Posts
    82

    resolved [RESOLVED] Weird Browser Scaling Issue

    I am building a site and when I scale the browser inside of 960px (the width of the site) the browser then gets a scroll bar. All is good here, but then when you actually scroll everything is cut off for some reason. Everything in the site has a div tag called "wrap" that is 100% and then the content div is set at 960px. Any idea what is happening here?

    Link to the site: www.andyrichin.com/index.php

    Scale the browser then scroll horizontally and you'll see. Thanks in advance!

  2. #2
    Join Date
    Nov 2011
    Posts
    82
    So I realized by setting the "wrap" div to 960 and not 100% it stops it. However, what other solution is there to keep the black nav bar span the width of the browser?

  3. #3
    Join Date
    Aug 2012
    Location
    Canada
    Posts
    56
    You have a problem with the validation of your HTML 38 errors in the validator, though I think for the most part it is caused by the unclosed <a name tag at the beginning of the body. As for getting the nav more flexible set the width to 98% with margin:auto
    Cd&
    one of my toys And my repository and my old self ranting plus a bonus Getting the most out of Q/A sites
    Code that is 100% standards compliant is 100% correct 100% of the time... anything else is just a hack

  4. #4
    Join Date
    Nov 2011
    Posts
    82
    Thanks I figured it out. I was setting my "wrap" div which was wrapping the content to 100%. I just set it to 980px and it's fine. Thanks tho!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles