www.webdeveloper.com
Results 1 to 3 of 3

Thread: menu - firebug please

  1. #1
    Join Date
    Jun 2011
    Posts
    13

    menu - firebug please

    Hi all,

    I have tried to find this in firebug but so far I can't find it. Can anyone please tell me what is causing link 1 to be be bigger than the others?

    Thanks...

  2. #2
    Join Date
    Mar 2011
    Posts
    1,140
    You've got a <br> after the <a></a> in the <li> that contains Link 1 which isn't helping, but I'm pretty sure the problem is that the <ul id="submenu"> needs to be set to display:none:. Try:
    Code:
    .dropdown_menu ul li ul { display:none; }
    .dropdown_menu ul li:hover > ul {
    	display: block;
    }
    Rick Trethewey
    Rainbo Design

  3. #3
    Join Date
    Jun 2011
    Posts
    13
    Quote Originally Posted by rtrethewey View Post
    You've got a <br> after the <a></a> in the <li> that contains Link 1 which isn't helping, but I'm pretty sure the problem is that the <ul id="submenu"> needs to be set to display:none:. Try:
    Code:
    .dropdown_menu ul li ul { display:none; }
    .dropdown_menu ul li:hover > ul {
    	display: block;
    }
    @ rtrethewey awesome thank you, here it is after your corrections. One problem left - there is too much black when the menu drops down (attached) - any ideas for that please?
    Attached Images Attached Images

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles