www.webdeveloper.com
Results 1 to 6 of 6

Thread: Simple Header Issue

  1. #1
    Join Date
    Jan 2013
    Posts
    5

    Simple Header Issue

    Hi there,

    I am just putting the finishing touches on an eCommerce site I have been working on for a few months.

    My issue is with the header. If the page is viewed in either Firefox or Internet Explorer, the header looks as it should. But when I attempt to view the site in Google Chrome or Safari, the website appears to apply the background image between two divs, rather than the single div behind the front divs.

    I have been over my code several times, but cannot seem to figure out what it is that is causing this issue. I am sure that it is a simple issue, and I would greatly appreciate any help which could be provided.

    http://temp2692.smartetailing.com/

    Thank you,
    Paul

  2. #2
    Join Date
    Mar 2011
    Posts
    1,110
    That page has some serious issues. I did a 'View Source' and scrolled down through the code and found what looks like several top sections appended to the start of the page, with multiple <!DOCTYPE> and <html> tags. So you need to start by fixing that problem.
    Rick Trethewey
    Rainbo Design

  3. #3
    Join Date
    Jan 2013
    Posts
    5
    Thank you for noticing that! I forgot to remove those tags when I was inputting the code into the template.

    Any ideas regarding the header?

  4. #4
    Join Date
    Mar 2011
    Posts
    1,110
    You've still got lots of stray HTML mark-up scattered through your code. Try running it through http://validator.w3.org/
    Rick Trethewey
    Rainbo Design

  5. #5
    Join Date
    Jul 2009
    Posts
    32
    Yes Validate your code pls.. its a mess! i saw atleast 3 separate <head></head> & <body></body> tags scattered in your code.. that is very very bad if you plan on debugging browser inconsistencies. Checked in chrome you have a bug with the header bg behind the search field.. more likely due to your messed up HTML because the image is actually 1 graphics... What cart system are you using ?

    Other than that really nice website. I'm a huge MTB fan myself

  6. #6
    Join Date
    Jan 2013
    Posts
    5
    Wow...I didn't realize there were so many tags. Thanks for noticing that. I'll let you know when I'm finished, and then maybe you can take a look at the header.

    Thanks again!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles