Good morning all!

I'm having trouble with my internal DNS that my hosting company hasn't been able to help me with, so I searched for a community of people who have been doing this for ages to, hopefully, get some assistance. I know this is kind of long winded but I don't really know how to describe the problem any more succincly, so I apologize.

Here's the situation in brief. Our website used to be hosted on a Windows server that we rented out of a data center and administered directly through remote desktop and IIS. A few months ago we hired a web developer to revamp the site and he moved us to a solution hosted with Bluehost on a LAMP server. The site is at, which also happens to be the internal name of our domain set up through Small Business Server.

When we were still self-hosted, users internally couldn't access the website in their browser with - it tried to take them to an intranet site on the Small Business Server. You had to use to tell the computer you wanted a resource not hosted within the local network. When we moved over to Bluehost, we created a www record in our internal DNS manager that led to the new web server's IP address: That worked, no problem.

Just this week, we decided to start a knowledgbase to keep some internal information, so I installed a wiki on the Bluehost server in a subfolder: If I am outside the company's network - on my cell phone, at home, anywhere, I can access the site no problem. But inside the network, the one place I actually need access to this resource, I cannot get through. I'm getting a 404 error:

HTTP Error 404 - File or directory not found.
Internet Information Services (IIS)

IIS is the platform we were using when we self hosted; does this mean the DNS thinks this traffic should go to the old server instead of the new one? The funny thing is, if I enter the direct URL of a test image I created,, I can access that on our internal network. But if I modify that to the index page of the wiki,, I get a 404 error. If the problem really were DNS related, then I would be unable to access anything in that folder regardless of file type... right? And it was my understanding that DNS only dealt with top level domains anyway, so anything in a subfolder should be accessable since it's a part of the same site.

I'm sorry this post goes on and on and on but I hope providing all the details I can makes it easier to solve the issue. I'm pulling my hair out, I'm well out of my depth with this issue, and I have about 6 angry users clamoring for this thing to be up and running yesterday, so any help anyone can offer about configring this - either on the SBS server or on the Bluehost side, would be greatly appreciated.