Hi guys and gals, I'm new here so bare with me:

I'm having some trouble embedding a video on a site and so far this is how my testing has gone:

1.) It works on my local server for these browsers: Safari, Chrome, Firefox.... Except for IE9
2.) On a remote server (Godady/Windows server running IIS 7.0)... the video works good with Safari ...but none of the other browsers.

Here is my css/html code:

<video width="900" height="820" autoplay="true">
<source src="video/video.mp4" type="video/mp4">
<source src="video/video.ogv" type="video/ogg">
<source src="video/video.webm" type="video/webm">
<source src="video/video.flv" type="video/x-flv">
</video>

I recognized that some of the file types were not recognized as I saw an error message saying this, so I figured I needed to add new MIME types as I didn't see ogg, webm, mp4 video (just mp4 audio) on the list.

Godaddy doesn't seem to have an editable web.config file (which they confirmed), so I attempted to create one as they suggested. I saved it as web.config.xml (is this right?),
and this is what I added:

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<system.webServer>
<staticContent>
<mimeMap fileExtension=".mp4" mimeType="video/mp4" />
<mimeMap fileExtension=".ogv" mimeType="video/ogg" />
<mimeMap fileExtension=".flv" mimeType="video/x-flv" />
<mimeMap fileExtension=".webm" mimeType="video/webm" />
</staticContent>
</system.webServer>
</configuration>

But I'm still not getting video for the other browsers, except for Safari even with the web.config additions.

Can anyone see anything wrong with my code? Or better yet, add suggestions that they've used that worked? Any clues would help.

Note: I saved the mp4 as an h.264 compressed file, as some browser can only handle this type for the mp4. Do I need additional code to make this work on Firefox, Chrome, IE?

Thanks in advance for your help.