www.webdeveloper.com
Results 1 to 8 of 8

Thread: [RESOLVED] Hover menu not working properly...

  1. #1
    Join Date
    Dec 2012
    Posts
    81

    resolved [RESOLVED] Hover menu not working properly...

    Please have a look at this link. I've got most of the menu working, but for some reason, the hover option isn't working.

    The CSS looks clean and I think I've accounted for everything.

    http://webfro.gs/south/kb3/


    Thanks,

    Jared

  2. #2
    Join Date
    Sep 2008
    Location
    Akron, OH
    Posts
    1,129
    The hover seems to be working for me on the top nav. What exactly isn't working?
    I'm always up for networking with fellow web professionals. Connect with me on LinkedIn if you like!

  3. #3
    Join Date
    Dec 2012
    Posts
    81
    Sorry... I realized I wasn't very clear in my initial post.

    Under Tools and Compliance, I have drop down lists (see source code) and nothing's dropping down on hover.

  4. #4
    Join Date
    Dec 2012
    Posts
    81
    Hey Dan... I figured it out. I was missing some essential JS. Thanks...

  5. #5
    Join Date
    Sep 2008
    Location
    Akron, OH
    Posts
    1,129
    Gotcha. You could achieve it with pure CSS by adding this:

    Code:
    #south_menu ul li:hover ul {display: block; visibility: visible;}
    I'm always up for networking with fellow web professionals. Connect with me on LinkedIn if you like!

  6. #6
    Join Date
    Dec 2012
    Posts
    81
    I tried that and it might work for me. For now, I have something else to consider. Can you open that page in IE?

    http://webfro.gs/south/kb3/

    I'm working with IE8 at the corporate level. I don't have any choice. I have to try and get this to work in that version. If you hover over the menu now, it appears to drop the menu behind my <h1> divs. Any idea on how to "layer" that so the menu is on top?

  7. #7
    Join Date
    Dec 2012
    Posts
    81
    Nevermind... I have so much to do and I keep not thinking before I blog. I added a z-index and that solved the issue.

  8. #8
    Join Date
    Feb 2013
    Location
    USA
    Posts
    40
    Thanks for taking the time to discuss this, I feel strongly about it and love learning more on this topic.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles