I have a Google Chrome extension, that consists of 4 .JS, 1 .JSOn and 1 .html files.

Basically in short, this program allows me to type a keyword of a item that is sold via Nike Twitter. When Nike Twitter Tweets the link, (usually at 8aM), this program will/is suppose to open the link that they tweeted into a new tab, and have the shoe size ready in it, all good for checkout.

A short while ago, Twitter updated their API, putting this bot in a state of no use. I want to use it, but I can't get it working because I don't know ANYTHING about dealing with this sort of stuff.

The error I get when I click generate background option is; {"errors": [{"message": "The Twitter REST API v1 is no longer active. Please migrate to API v1.1. https://dev.twitter.com/docs/api/1.1/overview.", "code": 68}]}
1


So I'm assuming I have to some how update it, but I have no idea, and NEED HElP. Either if someone can tell me how to do it, or if they can do it for me and I pay them via Paypal or whatever.

Please!