I've been trying to setup mysql properly, but it isn't working. This won't be locally stored [One VPS, I meant not locally on my own hard drive. It will be on one linode.], so from my own understanding I shouldn't be using 'kai'@'localhost' rather I use @'%' correct? I have tried following guides everywhere I could find, but they don't get it working. I want to setup a database called 'eve' and have a user on it called 'kai'. It's not that I'm unwilling to learn but it's on Linux and I don't have cpanel with my host. I have set up the database, mysql, etc. I've also tried setting up phpmyadmin but it made things more confusing. I took a step back to use ssh mysql commands being I only need one table and user.? So far:

create user 'kai'@'%' identified by password 'mypass';
grant all privileges on . to 'kai'@'%' with grant option;
ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'grant all privileges on . to 'kai'@'%' with grant option' at line 1

that's one example

I've tried several different ways including @%, @localhost, etc. i tried going through the mysql guide they have in place, but it didn't help too much. I considered maybe I needed to use @192., etc, but I don't think that'd be secure.

Any pointers would be excellent, I'm sure I'm just skipping something easy and I don't know the proper terminology to google or I would have found it already . This is on Debian 7 64bit, dunno how important that is but everything is updated, etc.

I've been following this: http://dev.mysql.com/doc/refman/5.5/...ing-users.html

errors I've been having: 1396, 1064 and a couple of others. I'm essentially wanting to do what someone would normally easily do through cPanel, etc. but in a ssh client. If there's a way to setup something like that to where I would have a gui to work with, that'd be something I wouldn't have a problem trying.

Should I be using localhost? My IP? sdnam.net?

error 1396 create user 'kai'@'%' identified by password 'mypass'; ERROR 1396 (HY000): Operation CREATE USER failed for 'kai'@'%


edit upon completed attempts on the "application"(?) I'm trying to use it with I either have a server error (500) or
access denied for 'kai'@'localhost'
Query OK, 0 rows affected (0.00 sec)
checked the SHOW TABLES, had my user there in the right database, tried running the install and had this returned
Unable to connect to database and my index gives:

[1045] dbconn: mysql_connect: Access denied for user 'kai'@'localhost' (using password: YES)
Progress? :\