I found some working code on a Fiddle link, but it does not work when I make test html, css, js files on my harddrive.

The original code:
http://jsfiddle.net/92HXT/530/

In my html I added:
Code:
<script src="http://code.jquery.com/jquery-2.0.3.min.js"></script>
<script src="slider.js" type="text/javascript"></script>
I noticed that the jQuery UI 1.10.3 is required for the Fiddle code to work. I have never needed to implement ui to make anything work beyond the initial jQuery version.

Is this really necessary?