Results 1 to 3 of 3

Thread: Need Help Installing Laravel

  1. #1
    Join Date
    Jul 2013

    Need Help Installing Laravel

    I'm trying real hard to learn to use Laravel Framework.
    But, I'm stuck right in the beginning. I'm just not understanding how to install the framework and include it.
    Plus there are no pre-installed copies for download. And, I googled a lot but could not find any project source made using laravel.

    Anyways, all I need is some help. Could someone provide me with an installed copy of laravel? Or help me install it?

    I installed composer for windows and I downloaded laravel from here : https://codeload.github.com/laravel/laravel/zip/master

    Now, I extracted the archive and navigated to the folder containing composer.json through command prompt.
    After that, I executed composer install command.

    This is the output that it shows :
    Warning: This development build of composer is over 30 days old. It is recommend
    ed to update it by running "C:\ProgramData\Composer\bin\composer.phar self-updat
    e" to get the latest version.
    Loading composer repositories with package information
    zlib_decode(): data error
    http://packagist.org could not be fully loaded, package information was loaded f
    rom the local cache and may be out of date
      The "http://packagist.org/p/laravel/laravel$5b350a7b69bf221da439ce6c922730b
      734193cc4f3d4d8970d276b489b302bcd.json" file could not be downloaded (HTTP/
      1.1 404 Not Found)
    install [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--no-c
    ustom-installers] [--no-scripts] [--no-progress] [-v|vv|vvv|--verbose] [-o|--opt
    And I dont think anything is getting installed.

    What do I do?

  2. #2
    Join Date
    Oct 2014
    The packagist.org try to redirect you from HTTP to HTTPS, so you have to download Laravel manualy from :


    Unzip the file and add this lines to " composer.json " before the last line that conten this symbol " } "
    "repositories": [
    "type": "composer",
    "url": "https://packagist.org"
    { "packagist": false }

    Now cd to your project folder and type :

    Composer install

  3. #3
    Join Date
    Oct 2014
    Also try to update Composer first

    PHP composer.phar self-update


    composer self-update

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
HTML5 Development Center

Recent Articles