www.webdeveloper.com
Results 1 to 2 of 2

Thread: .php file blank - .php5 files works

  1. #1
    Join Date
    Aug 2010
    Posts
    20

    .php file blank - .php5 files works

    Hello,
    I have a problem with a server of mine. I have installed virtualmin/webin on it for administration and i have 1 domain on it. Dns management is external. I had on this domain only an html "Under Construction" index and 5 subdomains. In all those subdomains i have php systems running perfectly. I have tried to install wordpress on the main domain and i'm having some issues: None .php files loads. I have made a phpinfo file on it to check it and it wont work neither: appears a blank page. When i check the source code of it in browser, appears the code . I have changed the extensions to .php5 and it worked perfectly. Something is going wrong with it but i can't figure out what.
    I have checked the apache error and nothing appears :?
    3 Days ago i have upgraded from php 5.2.* to 5.4.21.
    Server is running centos 5.10.
    Hope that someone can help me on this issue :/
    Thank you in advance!

  2. #2
    Join Date
    Aug 2010
    Posts
    20
    This is the httpd.conf
    Code:
    SuexecUserGroup "#509" "#504"
    ServerName domain.tld
    ServerAlias www.domain.tld
    ServerAlias webmail.domain.tld
    ServerAlias admin.domain.tld
    ServerAlias autoconfig.domain.tld
    DocumentRoot /home/domain/public_html
    ErrorLog /var/log/virtualmin/domain.tld_error_log
    CustomLog /var/log/virtualmin/domain.tld_access_log combined
    ScriptAlias /cgi-bin/ /home/domain/cgi-bin/
    ScriptAlias /awstats/ /home/domain/cgi-bin/
    ScriptAlias /autodiscover/autodiscover.xml /home/domain/cgi-bin/autoconfig.cgi
    DirectoryIndex index.html index.htm index.php index.php4 index.php5
    <Directory /home/domain/public_html>
    Options -Indexes +IncludesNOEXEC +SymLinksIfOwnerMatch +ExecCGI
    allow from all
    AllowOverride All Options=ExecCGI,Includes,IncludesNOEXEC,Indexes,MultiViews,SymLinksIfOwnerMatch
    AddHandler fcgid-script .php
    AddHandler fcgid-script .php5
    FCGIWrapper /home/domain/fcgi-bin/php5.fcgi .php
    FCGIWrapper /home/domain/fcgi-bin/php5.fcgi .php5
    </Directory>
    <Directory /home/domain/cgi-bin>
    allow from all
    AllowOverride All Options=ExecCGI,Includes,IncludesNOEXEC,Indexes,MultiViews,SymLinksIfOwnerMatch
    </Directory>
    RewriteEngine on
    RewriteCond %{HTTP_HOST} =webmail.domain.tld
    RewriteRule ^(.*) https://domain.tld:20000/ [R]
    RewriteCond %{HTTP_HOST} =admin.domain.tld
    RewriteRule ^(.*) https://domain.tld:10000/ [R]
    RemoveHandler .php
    RemoveHandler .php5
    php_admin_value engine Off
    IPCCommTimeout 31
    Alias /dav /home/domain/public_html
    Alias /pipermail /var/lib/mailman/archives/public
    <Location /dav>
    DAV on
    AuthType Basic
    AuthName "domain.tld"
    AuthUserFile /home/domain/etc/dav.digest.passwd
    Require valid-user
    ForceType text/plain
    Satisfy All
    RemoveHandler .php
    RemoveHandler .php5
    RewriteEngine off
    </Location>
    <Files awstats.pl>
    AuthName "domain.tld statistics"
    AuthType Basic
    AuthUserFile /home/domain/.awstats-htpasswd
    require valid-user
    </Files>
    RedirectMatch /cgi-bin/mailman/([^/\.]*)(.cgi)?(.*) https://domain.tld:10000/virtualmin-mailman/unauthenticated/$1.cgi$3
    RedirectMatch /mailman/([^/\.]*)(.cgi)?(.*) https://domain.tld:10000/virtualmin-mailman/unauthenticated/$1.cgi$3
    Redirect /mail/config-v1.1.xml /cgi-bin/autoconfig.cgi
    php_value memory_limit 32M

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles