I am trying to configure PHP with Apache Http Server on my Windows 7 Laptop.

Apache MSI - httpd-2.2.25-win32-x86-no_ssl.msi PHP ZIP - php-5.5.6-Win32-VC11-x86.zip

For PHP I did the following
1. Renamed php.ini-development to php.ini
2. In php.ini removed ; (uncommented) in front of extension_dir and given the path for extension_dir as "C:\PHP\ext". C:\PHP is where my PHP files are unzipped to.
3. In php.ini removed ; in front of extension=php_mysql.dll

For Apache in C:\Program Files (x86)\Apache Software Foundation\Apache2.2\conf\httpd.conf made the following changes
1. Added LoadModule php6_module "C:\PHP\php5apache2_4.dll"
2. Added
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps
PHPIniDir "C:\PHP"

But while trying to restart Apache Service I am getting the error Cannot load C:/PHP/php5apache2_4.dll into server: The specified procedure could not be found.

I tried with different versions of PHP zip like php-5.4.22-Win32-VC9-x86.zip and php-5.3.27-Win32-VC9-x86.zip. But same error.

In one of the PHP forums I found that if VC++ redistributable package is installed the error will be solved. VC++ redistributable package was installed already even then i downloaded again and installed still same error.

In othere post it was mentioned that using VC6 of PHP will solve this. I could not find VC6.

I am just begining my adventure with PHP, it would be great if any one can help me with this issue in setting up the environment.

** Steps which i am following from wrox book mentions to copy libmysql.dl from c:\PHP to c:\Windows\System32 or C:\WINNT\System32. But I could not find libmysql.dll in any of the versions of zip that I used.