www.webdeveloper.com
Results 1 to 8 of 8

Thread: Good CSS & HTML doesn't work. [HEADACHE AWARE!!!]

  1. #1
    Join Date
    Aug 2013
    Posts
    57

    Good CSS & HTML doesn't work. [HEADACHE AWARE!!!]

    Hello

    My URL's in this navbar doesn't work, the funny part is that I do have the same navbar on other pages and I just copy paste the code to my this page. It's a PHP page, but when I change it to .html it doesn't work either.

    So, the same codes, does work on page A but not on page B...

    CSS:
    Code:
    .c4 {
    border: solid 2px;
    border-color:#FF6600;
    width:7.451%;
    position:absolute; top:413px; left:9.50em;
    }
    .c5 {
    color:#FFFFFF;
    background-color:#FF6600;
    font-family:Arial;
    width:100px;
    border: solid 1px;
    border-color:#FF3300;
    border-radius:1px;
    }
    
    .c7 {
    text-decoration:None;
    color:#FF6600;
    border:solid 1px;
    border-color:#BDBDBD;
    width:100px;
    }
    .c7:hover {
    color:#0033FF;
    text-decoration:Underline;
    }
    HTML:
    Code:
    <!--Navbar-->
    <div class="c4">
    <div class="c5">About:</div>
    <div class="c6">
    <a class="c7" href="forum.html">Our forum</a>
    <a class="c7" href="aboutus.html">About iCode4U</a>
    <a class="c7" href="getyoursite.html">Get your site</a>
    <br><a class="c7" href="ourstaff.php">Our staff</a>
    <br><a class="c7" href="https://twitter.com/OfficialiCode4U">Our Twitter</a>
    <br><a class="c7" href="https://www.facebook.com/icode.foru">Our Facebook</a>
    <div class="c5">Other:</div>
    <a class="c7" href="http://www.zeldauniverse.net">ZeldaUniverse</a>
    <br><a class="c7" href="http://www.facebook.com">Facebook</a>
    <br><a class="c7" href="http://www.Twitter.com">Twitter</a>
    </div>
    <!--Navbar-->
    What's wrong with this?
    My site isn't online yet.

    The URL doesn't even hover and they should be.

    Thanks for reading,

    Niely

  2. #2
    Join Date
    Dec 2013
    Posts
    11
    Try to change the main method of html.

  3. #3
    Join Date
    Aug 2013
    Posts
    57
    ^What do you mean exactly?

  4. #4
    Join Date
    Mar 2011
    Posts
    1,147
    You can't just copy and paste HTML and CSS from one page into another and always expect it to work. Many CSS settings (like "position:absolute") rely on their context within the entire document. And without seeing the entire document, it's impossible to diagnose the trouble in this instance. If you'll post a link to the page you're having trouble with, someone will help you. But you should also work on building your CSS skills so you'll know what to look for when problems arise. Good luck!

  5. #5
    Join Date
    May 2005
    Location
    Gold Coast (MS)
    Posts
    2,217
    Best to check for coding errors and correct those.

    Validating:

    Why Validate?
    CSS Validator
    HTML Validator
    But It Doesn't Validate

  6. #6
    Join Date
    Sep 2006
    Location
    new york
    Posts
    267
    Would have to see online site to be sure, but my guess is that you may have some folders here ???

    When linking from home page index.html (which sits on top, or outside of, folders) you just use href="forum.html". But , if forum.html is in a folder, you have to dig out of the folder with ../ to go back to home ../index.html.

  7. #7
    Join Date
    Aug 2013
    Posts
    57
    I haven't got any folders.

    But I think I will just re-write my whole navbar, it's just two pages. I will let you guys know something when I'm ready!

  8. #8
    Join Date
    Aug 2013
    Posts
    57
    Nope, rewrited my whole HTML & CSS for navbar and still doesn't work...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles