www.webdeveloper.com
Results 1 to 4 of 4

Thread: link to external site has IP addy of webserver prefixing it--404 error

  1. #1
    Join Date
    Mar 2014
    Posts
    2

    link to external site has IP addy of webserver prefixing it--404 error

    hello,
    I am a tinkerer and am self hosting some sites on a linux box and am seeing some odd behavior. Using either kompozer or blue griffon i set a link to an external site--check the box "relative to page location"
    and the source code looks right with the normal a href "www.external site" </a> link text</a> ....however when clicking the link it prefixes it with the IP addy/port of the webserver then the link to the external site and of course I get a 404 as the address is hokey. if I uncheck the box relative to page location it has the ///var/www/html/path to index.html
    I have setup pages previously and have not seen this occur...any ideas of why this is occuring?

  2. #2
    Join Date
    Mar 2014
    Location
    UAE
    Posts
    98
    Contact your hosting provider they can help you essaly

  3. #3
    Join Date
    Mar 2014
    Posts
    2
    Quote Originally Posted by Digitalgarden View Post
    Contact your hosting provider they can help you essaly
    I'm self hosted--there is not hosting company--running apache in linux

  4. #4
    Join Date
    Aug 2006
    Posts
    1,934
    Show us that actual <a> link. I'm guessing it's missing http:// in front of it, or a similar syntax error.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles