dcsimg
www.webdeveloper.com
Results 1 to 5 of 5

Thread: Encoding messes up my layout on Internet Explorer

  1. #1
    Join Date
    Aug 2006
    Posts
    152

    Question Encoding messes up my layout on Internet Explorer

    Hello Everyone,

    I'm facing a weird problem with my website, it was running on encoding windows-1256 just fine on all browsers.. but I decided to convert to UTF-8 but unfortunately the layout is all messed up on internet explorer, works fine on firefox.. any idea what might be causing this?

    I used Notepad++ to convert my file formats..

    Any one faced this issue before?

    Thank You,,

  2. #2
    Join Date
    Aug 2006
    Posts
    152
    Update: If I change the file encoding to UTF-8 Without BOM it seems to work fine.. However I heard it's not preferable using this encoding..

  3. #3
    Join Date
    Mar 2012
    Posts
    1,833
    Wikipedia says:
    The Unicode Standard permits the BOM in UTF-8, but does not require or recommend its use. Byte order has no meaning in UTF-8,

  4. #4
    Join Date
    Aug 2006
    Posts
    152
    If it has no meaning then why is the page messed up on UTF-8 but works fine with UTF-8 without BOM?

  5. #5
    Join Date
    Mar 2012
    Posts
    1,833
    Presumably because it is not expected.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles