dcsimg
www.webdeveloper.com
Results 1 to 2 of 2

Thread: <audio> not playing in IE

  1. #1
    Join Date
    Nov 2005
    Location
    Bundanoon: first village to ban bottled water
    Posts
    221

    <audio> not playing in IE

    Hi,

    Having a problem getting IE to play <audio>.

    I'm testing locally: IE 10 on Windows 7 Enterprise, Service Pack 1.

    The idea is to have the audio play automatically, and to have a function triggered more or less when the audio starts--preferably, "oncanplaythrough".

    But IE doesn't acknowledge this event, so I've tried "oncanplay", and "onplay", and IE responds to neither.

    <audio preload="auto" autoplay="autoplay" onplay="myfunction();"><!-- oncanplaythrough="myfunction();" oncanplay="myfunction();" -->
    <source src="my.mp3" />
    <source src="my.ogg" />
    your current browser does not support the new audio standard: upgrade if you can.
    </audio>

    Chrome and Firefox respond to any of the three events.

    I must be doing something wrong: would it be to do with testing locally?

  2. #2
    Join Date
    Nov 2005
    Location
    Bundanoon: first village to ban bottled water
    Posts
    221

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles