Results 1 to 7 of 7

Thread: Error 2003 MySQL 5.5.57 Raspian

  1. #1
    Join Date
    Dec 2010
    Newton Aycliffe, Co Durham, England

    Error 2003 MySQL 5.5.57 Raspian

    I am trying to set up replication across 2 raspberry Pi's, MYSQL master and slave. I have had this set up working before. The problem I get is that the slave IO thread constantly says 'Connecting' and then does not connect. The Slave SQL is running.

    I have unique server ID in the my.cnf files, I have deleted all log files in the /var/log/mysql folders and restarted mysql. I have the correct user on the master, the correct IP address for the Master, basically, I have set this up by the book. My error log is giving me a code 2003, network error, but I can ping, VNC, SSH and use PhpMyAdmin on the master. All work perfectly. I can even log in using PhpMyAdmin on the master from the slave Pi. I have used Netsat to check port 3306. All ok.

    Is this a bug? I have been trying everything on Google for 3 days. I'm out of ideas.

  2. #2
    Join Date
    Mar 2007
    This could be anything...

    Software, hardware setting, switch setting, faulty cable...

    Are you sure that the mysql service is running properly on both devices and you can access both from an external device linked to the network.

    Have you ruled out that its not a faulty cable or a connector needs cleaning, that the devices you are using have had the IP addresses of the devices correctly and that they have unique ip addresses, I assume you did that bit correctly because you said that "All worked Perfectly" so that means something may not be working or running that needs starting again...
    --> JavaScript Frameworks like JQuery, Angular, Node <--
    ... and please remember to wrap code with forum BBCode tags:-

    [CODE]...[/CODE] [HTML]...[/HTML] [PHP]...[/PHP]

    If you can't think outside the box, you will be trapped forever with no escape...

  3. #3
    Join Date
    Dec 2010
    Newton Aycliffe, Co Durham, England
    Thank you for the response.

    I have tried changing the network cables and I can also access both Pi's from an Ubuntu 16.04 pc on the network. Fully confident it's a MYSQL fault not a simple hardware issue. I was hoping it would be a recognised fault. Guessing not.

  4. #4
    Join Date
    Dec 2010
    Newton Aycliffe, Co Durham, England
    Should have also said that I tried to set the Ubuntu machine up as a slave and it also could not connect to the master.

  5. #5
    Join Date
    Dec 2010
    Newton Aycliffe, Co Durham, England
    Logic therefore suggests the Ethernet port on the Pi, but why can it connect with all the other services and not MYSQL even though it checks out correctly? I really am baffled.

  6. #6
    Join Date
    Dec 2010
    Newton Aycliffe, Co Durham, England
    I've had a further thought that will require checking elsewhere. I modified the Pi to run from a USB memory stick rather than the fragile SD card. I wonder if the serial port architecture could be the issue.

  7. #7
    Join Date
    Dec 2010
    Newton Aycliffe, Co Durham, England
    I found a work around that seems to have solved all the problems. I set the bind address in the master my.cnf to the local IP of the Pi. In this case I then changed the mysqli_connect connection string in the website to point to that IP address instead of the standard Everything seems to work now, but I still haven't figured out why. I've been doing this stuff for 20 years now and I've never seen that solution, which scares me a little! If I do find any problems, I'll post back.

    Super Moderator, thanks for your time yesterday.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
HTML5 Development Center



X vBulletin 4.2.2 Debug Information

  • Page Generation 0.11122 seconds
  • Memory Usage 2,896KB
  • Queries Executed 15 (?)
More Information
Template Usage (32):
  • (1)ad_footer_end
  • (1)ad_footer_start
  • (1)ad_global_above_footer
  • (1)ad_global_below_navbar
  • (1)ad_global_header1
  • (1)ad_global_header2
  • (1)ad_navbar_below
  • (1)ad_showthread_firstpost_sig
  • (1)ad_showthread_firstpost_start
  • (1)ad_thread_first_post_content
  • (1)ad_thread_last_post_content
  • (1)footer
  • (1)forumjump
  • (1)forumrules
  • (1)gobutton
  • (1)header
  • (1)headinclude
  • (1)headinclude_bottom
  • (7)memberaction_dropdown
  • (1)navbar
  • (4)navbar_link
  • (1)navbar_moderation
  • (1)navbar_noticebit
  • (1)navbar_tabs
  • (2)option
  • (7)postbit
  • (7)postbit_onlinestatus
  • (7)postbit_wrapper
  • (1)spacer_close
  • (1)spacer_open
  • (1)tagbit_wrapper 

Phrase Groups Available (6):
  • global
  • inlinemod
  • postbit
  • posting
  • reputationlevel
  • showthread
Included Files (26):
  • ./showthread.php
  • ./global.php
  • ./includes/class_bootstrap.php
  • ./includes/init.php
  • ./includes/class_core.php
  • ./includes/config.php
  • ./includes/functions.php
  • ./includes/functions_navigation.php
  • ./includes/class_friendly_url.php
  • ./includes/class_hook.php
  • ./includes/class_bootstrap_framework.php
  • ./vb/vb.php
  • ./vb/phrase.php
  • ./includes/functions_facebook.php
  • ./includes/functions_calendar.php
  • ./includes/functions_bigthree.php
  • ./includes/class_postbit.php
  • ./includes/class_bbcode.php
  • ./includes/functions_reputation.php
  • ./includes/functions_notice.php
  • ./packages/vbattach/attach.php
  • ./vb/types.php
  • ./vb/cache.php
  • ./vb/cache/db.php
  • ./vb/cache/observer/db.php
  • ./vb/cache/observer.php 

Hooks Called (73):
  • init_startup
  • friendlyurl_resolve_class
  • init_startup_session_setup_start
  • database_pre_fetch_array
  • database_post_fetch_array
  • init_startup_session_setup_complete
  • global_bootstrap_init_start
  • global_bootstrap_init_complete
  • cache_permissions
  • fetch_postinfo_query
  • fetch_postinfo
  • fetch_threadinfo_query
  • fetch_threadinfo
  • fetch_foruminfo
  • load_show_variables
  • load_forum_show_variables
  • global_state_check
  • global_bootstrap_complete
  • global_start
  • style_fetch
  • global_setup_complete
  • showthread_start
  • showthread_getinfo
  • strip_bbcode
  • friendlyurl_clean_fragment
  • friendlyurl_geturl
  • forumjump
  • cache_templates
  • cache_templates_process
  • template_register_var
  • template_render_output
  • fetch_template_start
  • fetch_template_complete
  • parse_templates
  • fetch_musername
  • notices_check_start
  • notices_noticebit
  • process_templates_complete
  • friendlyurl_redirect_canonical
  • showthread_post_start
  • showthread_query_postids
  • showthread_query
  • bbcode_fetch_tags
  • bbcode_create
  • showthread_postbit_create
  • postbit_factory
  • postbit_display_start
  • postbit_imicons
  • bbcode_parse_start
  • bbcode_parse_complete_precache
  • bbcode_parse_complete
  • postbit_display_complete
  • memberaction_dropdown
  • tag_fetchbit
  • tag_fetchbit_complete
  • forumrules
  • navbits
  • navbits_complete
  • build_navigation_data
  • build_navigation_array
  • check_navigation_permission
  • process_navigation_links_start
  • process_navigation_links_complete
  • set_navigation_menu_element
  • build_navigation_menudata
  • build_navigation_listdata
  • build_navigation_list
  • set_navigation_tab_main
  • set_navigation_tab_fallback
  • navigation_tab_complete
  • fb_like_button
  • showthread_complete
  • page_templates