Hi there,
I got this PHP code that creates a vCard from data out of a MySQL database. I all works perfectly fine except for the special characters (since I'm from Germany these would be ,, and so on) they all get lost on the way. What do I need to do to fix this.

thanks for your help. :-)

PHP Code:
<?php
ob_start
();
include(
"connect.php");

... 
bunch of MySQL Statements

?>
BEGIN:VCARD
VERSION:3.0
N:<?php echo @mysql_result($name01); ?>;<?php echo @mysql_result($name02); ?>;;;
FN:<?php echo @mysql_result($name02) . " " . @mysql_result($name01) . "\n"?>
ORG:<?php echo @mysql_result($name06); ?>;
TITLE:<?php echo @mysql_result($name06) . "\n"?>
EMAIL;type=INTERNET;type=HOME;type=pref:<?php echo @mysql_result($emailprivat00) . "\n"?>
EMAIL;type=INTERNET;type=WORK:<?php echo @mysql_result($emailfirma00) . "\n"?>
TEL;type=HOME:<?php echo @mysql_result($telefonprivat00) . "\n"?>
TEL;type=WORK:<?php echo @mysql_result($telefonfirma00) . "\n"?>
TEL;type=FAX:<?php echo @mysql_result($telefonfax00) . "\n"?>
TEL;type=CELL;type=pref:<?php echo @mysql_result($telefonmobil00) . "\n"?>
item2.ADR;type=HOME;type=pref:;;<?php echo @mysql_result($adresseprivat00); ?>;<?php echo @mysql_result($adresseprivat02); ?>;;<?php echo @mysql_result($adresseprivat01); ?>;<?php echo @mysql_result($adresseprivat03) . "\n"?>
item2.ADR;type=WORK;type=pref:;;<?php echo @mysql_result($adressefirma00); ?>;<?php echo @mysql_result($adressefirma02); ?>;;<?php echo @mysql_result($adressefirma01); ?>;<?php echo @mysql_result($adressefirma03) . "\n"?>
BDAY;value=date:<?php echo @mysql_result($geburtstag00) . "\n"?>
END:VCARD
<?php
$filename
=@mysql_result($name02) . " " . @mysql_result($name01);
header("Content-type: text/x-vcard");
header("Content-Disposition: attachment; filename=$filename.vcf");

mysql_close();
ob_end_flush();
?>