www.webdeveloper.com
Results 1 to 7 of 7

Thread: CDOSYS error

  1. #1
    Join Date
    Feb 2003
    Posts
    8

    CDOSYS error

    Error Type:
    CDO.Message.1 (0x8004020D)
    At least one of the From or Sender fields is required, and neither was found.
    /test/mail/moremail.asp, line 37

    This is the error I get when I ran David's CDOSYS snippet for sending email in win2k/asp3.Can anyone help with how to fix it, I am quite new at this.

  2. #2
    Join Date
    Jan 2003
    Location
    Dundee, Scotland
    Posts
    1,367
    hi,
    try this link to information about using CDO:
    http://www.aspfaq.com/show.asp?id=2026

  3. #3
    Join Date
    Feb 2003
    Posts
    8

    sorry! Dave

    Hi Dave attached is the entire code as per what you gave me yesterday.
    I have mail server name.
    I don't know if I have to do any configuration within IIS.
    This is my most recent error.

    Error Type:
    CDO.Message.1 (0x8004020C)
    At least one recipient is required, but none were found.
    /test/mail/moremail.asp, line 37
    Attached Files Attached Files

  4. #4
    Join Date
    Feb 2003
    Posts
    8
    Yeah Dave!
    I am in deed.
    Please have a look at line 34 of my code this requirement is satisfied.I am sure!
    I gather you are silent about whether anything is to be done on IIS to aid my solution.Is that a fact.
    This is killing me!
    Do I have to ponint to anything?
    Good Day.

  5. #5
    Join Date
    Jan 2003
    Location
    Dundee, Scotland
    Posts
    1,367
    hi,
    i think your problem maybe that you need to have your requst.form enclosed by " and " for some reason this would not work:
    Code:
    .To = variableemailaddress
    but this would:

    Code:
    .To = "&variableemailaddress&"
    so try changing you're code to this:

    Code:
    .To = "&Request.Form('recipient')&"
    or if that don't work try:

    Code:
    toaddress =  Request.Form("recipient")
    .To = "&toaddress&"
    I think this will be the case also for .From
    Hope this helps
    Last edited by Ribeyed; 02-21-2003 at 02:22 PM.

  6. #6
    Join Date
    Jan 2003
    Location
    Dundee, Scotland
    Posts
    1,367
    hi,
    yes Dave your correct. My syntax slightly off.

  7. #7
    Join Date
    Feb 2003
    Posts
    8
    Error Type:
    CDO.Message.1 (0x80040213)
    The transport failed to connect to the server.
    /test/mail/moremail.asp, line 42


    Hi Dave, since I tried your variations this is the error.
    Have you looked at my code in an editor at all?
    Would you be kind enough to ease the curve by addressing the line numbers to be affected.

    Also, I take it as whenever I change a ".To" variablename-
    I should change a corresponding ".From" variable name.

    I did not think sending mail will be so hard in asp.
    Its a duddle in CF(but I am quitting that) and this affair with asp is started rather strangely.Nevermind, lets keep trying.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles