dcsimg
www.webdeveloper.com
Results 1 to 2 of 2

Thread: visual web developer remote host

  1. #1
    Join Date
    Apr 2004
    Posts
    49

    visual web developer remote host

    greetings,

    I am redepoloying my site with the new Visual Web Developer. Unfortunately, I have run into a newbie snag... go figure..

    anyways... this one has been tormenting me for 2 days and I cant seem to get past it. Maybe you have a clue?

    running 2003 server
    .net 2.0 framework

    I can build the site with no problems locally on my xp machine and view the page from the localhost, but when I try to copy the site to my server, it shows up as page not found. I checked and rechecked all the permissions to make sure the read permission was set. it was.

    I tried it about 10 times before I decided to take a different approach... I created the virtual directory and left it essentially empty. Then I put the address into my browser, and viola... (with directory browse permission on of course) I can see the directory list. but the moment I create a web there, its not found.

    I tried every thign I could think of to view the page, and nothing (page not found), even though I am previewing it from the Visual Web Developer Solution Explorer menu (thus it obviously does exist in the web, and no chance to typo it that way).

    I made sure to be running the correct framework, and not accidentally to leave it on the 1.1.... i just dont get it. I have created many IIS 6 sites before with no problem, and as long as I create and view the site on localhost, it works, but only form that host. I have VWS installed on both the client and host, so I decided to try to build it right on the host, and got the same results; I can only view it from the host and not from the client this time.

    long winded story there for a simple problem... any idea what I missed?

  2. #2
    Join Date
    Apr 2004
    Posts
    49

    additionally....

    so, I decided to try creating a static web page in the
    empty web.

    I created one of those 'hello whirled' pages...

    perfectly functional.. I can view that page remotely
    without incident.

    I tried appending to its head, this code;

    <meta http-equiv="REFRESH" content="2;
    URL=http://192.168.1.25/default.aspx">

    in an wishful-thinking effort... without success.

    there appears to be something wrong with the codebase, or
    my IIS configuration. I cannot view any .aspx pages.

    When I look at the list of allowed 'web service
    extensions' the 'asp.net 1.1.4322' is set to allow. But
    dont I need the 2.0 here? If so, can someone tell me what
    I need to do to add this, if it is in fact what is
    holding me up here...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles