www.webdeveloper.com
Results 1 to 12 of 12

Thread: empty sent HTML's form ??

  1. #1
    Join Date
    Mar 2004
    Location
    Holland
    Posts
    139

    empty sent HTML's form ??

    Hello everybody,

    I try to send a form with the following HTML code but when i open my e-mail account, i find that the content is empty

    can anyone help me??

    <html>
    <body>
    <form action="MAILTO:telko@hotmail.com" method="post" enctype="text/plain">

    <h3>This form sends an e-mail to telko@hotmail.com.</h3>
    Name:<br>
    <input type="text" name="name"
    value="yourname" size="20">
    <br>
    Mail:<br>
    <input type="text" name="mail"
    value="yourmail" size="20">
    <br>
    Comment:<br>
    <input type="text" name="comment"
    value="yourcomment" size="40">
    <br><br>
    <input type="submit" value="Send">
    <input type="reset" value="Reset">

    </form>
    </body>
    </html>

  2. #2
    Join Date
    Nov 2002
    Location
    Auburn, AL
    Posts
    9,224
    You should really stop using mailto to send forms in the first place. The problem with mailto is that it depends on a users mail client to send the thing, not every user will use a mail client, for instance, people who use yahoo, msn, hotmail, aol, or any other number of webmail services will not be able to use your form properly unless they have their browser setup to use hosts servers. You should try to send the mail from your hosts smtp server if they allow you to use it, it would be in the hosts faq if you can. You will need to use a server side script to connect to the smtp server though. Who is your host, I might be able to help you figure out what your options are.

  3. #3
    Join Date
    Jul 2003
    Location
    New York City
    Posts
    2,771

  4. #4
    Join Date
    Mar 2004
    Location
    Holland
    Posts
    139
    thank uo all of you for answers,



    when I try to send my form using ASP on local computer , the e-mail go to the folder :

    C:\Inetpub\mailroot\Queue

    and they(the forms) are never sent to the appriate e-mail adres

    so I want use asp to send my form can any body help me??

  5. #5
    Join Date
    Nov 2002
    Location
    Auburn, AL
    Posts
    9,224
    what asp mail component are you using? I turned off email queing on my system. I am using asp.net myself.

  6. #6
    Join Date
    Mar 2004
    Location
    Holland
    Posts
    139
    Thank you PeOfEo for your answer, I'm using CDONTS.DLL

    but aal messages are queued in the folder ....\Queue

    Can somone help to get those messages sent to the appropriate
    e-mails?

    Thanx in advance

  7. #7
    Join Date
    Nov 2002
    Location
    Auburn, AL
    Posts
    9,224
    well this is weird. The mails should go into that folder before they are sent off, do you have an smtp server running or is mail queuing inabled or what? Is this the same server that is hosting the site? If not then try putting it on the final destination server and test it from that.

  8. #8
    Join Date
    Mar 2004
    Location
    Holland
    Posts
    139
    thank you for your answer,

    This is the same server that is hosting the site, I'm working on local computer. Juste want to test the working before I upload my site.

    Any help ?

    Thank you in advance.

  9. #9
    Join Date
    Nov 2002
    Location
    Auburn, AL
    Posts
    9,224
    Well, I mean the stuff is going into the folder on the personal pc that you are testing it on, so upload it and try to send an email after you do that.

  10. #10
    Join Date
    Mar 2004
    Location
    Holland
    Posts
    139
    thank you PeOfEo for your answer.
    do you mean that it is not possible to send an e-mail from a local computer despite I get a internet connection ?

    thanks imn advance

  11. #11
    Join Date
    Jul 2003
    Location
    New York City
    Posts
    2,771
    It is, but you need to have an SMTP server. I personally use Mercury Mail

  12. #12
    Join Date
    Nov 2002
    Location
    Auburn, AL
    Posts
    9,224
    There should be one that comes with iis, I believe. But you can also setup a third party on like listed above.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles