www.webdeveloper.com
Results 1 to 4 of 4

Thread: Validating css; It's all mumbo-jumbo to me

  1. #1
    Join Date
    Nov 2004
    Location
    Virginia Beach
    Posts
    59

    Validating css; It's all mumbo-jumbo to me

    Can anyone perhaps explain to me why my page isn't validating? The w3 website doesn't really explain in a way that's understandable to me what is wron with certain elements. Please take a look if you would.
    It mentions certain tags being open and not allowed etc. When I open the file in internet explorer it looks the way it should but in netscape it looks weird.
    Here is the web address...
    Graphic Ills

    Here is the css script:

    body { background-color: #FCFAFA; margin-top: 0px; margin-bottom: 0px; margin-left: 0px; margin-right: 0px;

    }
    h1 { font-size: 2em; font-family: arial; }
    p { font-size: 1.25em; text-align: left; margin-left: 2px; margin-bottom: 5px; }
    ul { list-style-type: circle; font-size: 1.25em; text-align: left; margin-left: 25px; }


    <!--

    DIV.Slice-01 {
    position: absolute;
    background: #991225;
    left: 0px;
    top: 0px;
    width: 200px;
    height: 130px;
    }

    DIV.Slice-02 {
    position: absolute;
    background: #991225;
    left: 260px;
    top: 0px;
    width: 480px;
    height: 130px;
    }

    DIV.Slice-03 {
    position: absolute;
    background: #e1e3e1;
    left: 0px;
    top: 130px;
    width: 740px;
    height: 88px;
    }

    DIV.Slice-04 {
    position:absolute;
    left: 0px;
    top: 240px;
    width: 147px;
    height: 47px;
    }

    DIV.Slice-05 {
    position: absolute;
    left: 147px;
    top: 219px;
    width: 3px;
    height: 801px;
    }

    DIV.Slice-06 {
    position: absolute;
    background: #e1e3e1;
    margin: 80px;
    left: 120px;
    top: 195px;
    width: 540px;
    height: 801px;
    text-align: right;
    color: #991225;

    }



    DIV.Slice-08 {
    position:absolute;
    left: 10px;
    top: 298px;
    width: 147px;
    height: 47px;
    }

    DIV.Slice-09 {
    position: absolute;
    left: 10px;
    top: 346px;
    width: 147px;
    height: 48px;
    }

    DIV.Slice-10 {
    position: absolute;
    left: 10px;
    top: 394px;
    width: 147px;
    height: 48px;
    }

    DIV.Slice-11 {
    position: absolute;
    left: 10px;
    top: 441px;
    width: 147px;
    height: 48px;
    }

    DIV.Slice-12 {
    position: absolute;
    background: transparent;
    left: 0px;
    top: 520px;
    width: 147px;
    height: 559px;
    }

    -->

  2. #2
    Join Date
    Jul 2004
    Location
    Sendai, Japan
    Posts
    1,273
    Hmmmm... seems fine to me.

  3. #3
    Join Date
    Feb 2003
    Location
    Michigan, USA
    Posts
    5,774
    The validation problem you are having is not a CSS one. The cause is an unclosed DIV tag: http://validator.w3.org/check?verbos...phic-ills.com/

    Almost without fail, if you design first in Internet Explorer, then it looks wrong in Netscape 7+, Opera, Safari, or Firefox, it's actually Internet Explorer that's wrong. Design first in Firefox and Opera. Then hack the style sheets to get it to work in IE.

  4. #4
    Join Date
    Nov 2004
    Location
    Virginia Beach
    Posts
    59
    Okay I found that extra little </div> and disposed of that. Strange thing is when you view the site in netscape it's showing something that's not even in the script. I deleted this small horizontal rule under the buttons but it's still showing as if it were still there. What the hell? It sucks too I can't even work on it at work because we're in a different workspace right now. So now there's no internet! ARRRgghh!! Anyway thanks for your help. When you guys view my page are using IE or Netscape or another browser? And how does it look to you?
    The part where it's gray is supposed to span across that entire area but in netscape it's only partially gray where the graphic is and the rest is black. The text is supposed to have a gray background. And the flower image is being cut off on the right side.
    That's when I view it using netscape. In IE it looks fine.
    Oh well probably won't have time this week to work on it

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles