Results 1 to 3 of 3

Thread: How do I find out why there's no sound on my PC?

  1. #1
    Join Date
    Mar 2004

    How do I find out why there's no sound on my PC?

    Hi folks. I've had no sound on my PC for a while now and I'd quite like to have it back.

    Here's what I did to lose it:

    Ok, I wanted to made a dual booting Windows/Linux machine, so I went to my local PC type things shop and grabbed a 40gig Maxtor HDD to chuck in so that I didn't have to worry about partitioning etc. I'm a bit of an idiot when it comes to things like that and thought it'd be best not to take any chances. So I whipped off the side of my box and chucked the second hard drive in the metal mounting case and screwed the mounting case back on to the side of the box. When it came to plugging in the wire from the electricity supply box thingy (A PSU?), I found that the morons at the factory had placed the connector for the second HDD nowhere near the end of the wire and was actually about 1.5 inch too far away from the mounting case which contaned both HDD's. My immediate reaction was to yank at the power cord for a bit to see if I could make it reach, you'll be amazed to hear I failed miserably. So, my next idea was to just unscrew the mounting case from the side of the box and just sort of wedge it in the hole it was meant to go in diagonally. That way the HDD's tilted to face the electric box thingy a bit more as thus make the wires reach. I slapped the side of the box back on to wedge the HDD's in place and got ready to install Linux...

    I made the PC boot from CD so that it would see the OS install disc and just went through the step by step installation guide. All went smoothly and away I went with my nice new OS. Then a few days later, a mate of mine with virtually the same hardware and had done exactly the same thing as me commented about the new message noise in kopete (a Linux equivelant of MSN), I said I hadn't noticed it, then I realised I hadn't noticed any sound coming from my PC. So, I chucked a CD in to see what would happen with that. It opened a CD player and said it was playing music, but no sound at all was coming out. I thought maybe I was just being a moron and hadn't sorted some setting for the new OS yet. I figured a quick test would be to boot Windows and see if that made any sound. Windows was now equally silent. I tried all kinds of things to make sure it wasn't just that I'd not wired the PC back up to the stereo properly (even plugging headphones directly into the machine its self, but still no sound came out.

    I don't have an actual sound card (or any kind of card for that matter) in the slots where they usually go. The sound output jack it attatched to the mother board, I'm guessing one of those chips on it is the GPU and one is the sound chip? Even the ethernet port is built in.

    I got rid of Windows a bit ago so now it's Linux only, but I'd like to have my sound back. Any ideas how I can find what the fault is? Currently my setup is Suse Linux 9.1, on x86 and like I said, I assume the other stuff is built into the mother board. I dunno if maybe I whacked the sound chip by accident when I was yanking on the electric box thingy wires or maybe something got wiped when I installed the OS or what.

    I got some info that might be useful to anyone that can understand it?
    Last edited by Mr Herer; 04-13-2005 at 05:53 AM.
    I'm thuper, thanks for asking.

    It lives! http://www.stephenphilbin.com/ (Well it kinda' does anyway).
    My portable colour selection tool

  2. #2
    Join Date
    Jan 2005
    I'm not very experienced with built in stuff, or linux for that matter, but training dictates the first things to do would be check every single volume control you can find and make sure nothing's muted or turned down. Since there are no cables to check, the next step (and this is the part that I'm unsure of due to built-in and linux) would be to see if you need to update, install, or reinstall your driver. This may not be the case though on a built-in system.

    It is also possible that you may have damaged the hardware in the installation or that the component was never fully functional. Have you ever heard sound from the machine and/or experienced problems with it?

    If I'm totally wrong on the driver thing, someone please correct me.

    Faster than an OC-48 Line! More powerful than an AMD Athlon 64 FX-55 Processor! Able to jump entire forums in a single bound!

    Roses are #FF0000, violets are #0000FF...

    Feeling the angst of a teenage torpor? Visit A to the Power of Two for help/hinderance.

    "...and the Lord said to John, Come forth and ye shall receive eternal life, but instead John came fifth and won a toaster."

    <pihlopase> Jesus Saves
    <jbroome> pases to moses, SCOOOOORE

  3. #3
    Join Date
    Feb 2003
    Wales, UK
    driver is the most common one.
    I'm getting a 'document contains no data' on your link.
    In a world without walls and fences - who needs Windows and Gates?! - Unknown Author
    "And there's Bill Gates, the...most...famous...man in the...ah...Microsoft." -- A TV commentator for the 2000 Olympics.

    Web Design Faq? | W3C | Validator | Accessibility testing | Speed up your PC | Wura | Box Model Research

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
HTML5 Development Center



X vBulletin 4.2.2 Debug Information

  • Page Generation 0.30507 seconds
  • Memory Usage 2,862KB
  • Queries Executed 13 (?)
More Information
Template Usage (32):
  • (1)ad_footer_end
  • (1)ad_footer_start
  • (1)ad_global_above_footer
  • (1)ad_global_below_navbar
  • (1)ad_global_header1
  • (1)ad_global_header2
  • (1)ad_navbar_below
  • (1)ad_showthread_firstpost_sig
  • (1)ad_showthread_firstpost_start
  • (1)ad_thread_first_post_content
  • (1)ad_thread_last_post_content
  • (1)footer
  • (1)forumjump
  • (1)forumrules
  • (1)gobutton
  • (1)header
  • (1)headinclude
  • (1)headinclude_bottom
  • (3)memberaction_dropdown
  • (1)navbar
  • (4)navbar_link
  • (1)navbar_moderation
  • (1)navbar_noticebit
  • (1)navbar_tabs
  • (2)option
  • (3)postbit
  • (3)postbit_onlinestatus
  • (3)postbit_wrapper
  • (1)spacer_close
  • (1)spacer_open
  • (1)tagbit_wrapper 

Phrase Groups Available (6):
  • global
  • inlinemod
  • postbit
  • posting
  • reputationlevel
  • showthread
Included Files (26):
  • ./showthread.php
  • ./global.php
  • ./includes/class_bootstrap.php
  • ./includes/init.php
  • ./includes/class_core.php
  • ./includes/config.php
  • ./includes/functions.php
  • ./includes/functions_navigation.php
  • ./includes/class_friendly_url.php
  • ./includes/class_hook.php
  • ./includes/class_bootstrap_framework.php
  • ./vb/vb.php
  • ./vb/phrase.php
  • ./includes/functions_facebook.php
  • ./includes/functions_calendar.php
  • ./includes/functions_bigthree.php
  • ./includes/class_postbit.php
  • ./includes/class_bbcode.php
  • ./includes/functions_reputation.php
  • ./includes/functions_notice.php
  • ./packages/vbattach/attach.php
  • ./vb/types.php
  • ./vb/cache.php
  • ./vb/cache/db.php
  • ./vb/cache/observer/db.php
  • ./vb/cache/observer.php 

Hooks Called (70):
  • init_startup
  • friendlyurl_resolve_class
  • init_startup_session_setup_start
  • database_pre_fetch_array
  • database_post_fetch_array
  • init_startup_session_setup_complete
  • global_bootstrap_init_start
  • global_bootstrap_init_complete
  • cache_permissions
  • fetch_threadinfo_query
  • fetch_threadinfo
  • fetch_foruminfo
  • load_show_variables
  • load_forum_show_variables
  • global_state_check
  • global_bootstrap_complete
  • global_start
  • style_fetch
  • global_setup_complete
  • showthread_start
  • showthread_getinfo
  • strip_bbcode
  • friendlyurl_clean_fragment
  • friendlyurl_geturl
  • forumjump
  • cache_templates
  • cache_templates_process
  • template_register_var
  • template_render_output
  • fetch_template_start
  • fetch_template_complete
  • parse_templates
  • fetch_musername
  • notices_check_start
  • notices_noticebit
  • process_templates_complete
  • friendlyurl_redirect_canonical
  • showthread_post_start
  • showthread_query_postids
  • showthread_query
  • bbcode_fetch_tags
  • bbcode_create
  • showthread_postbit_create
  • postbit_factory
  • postbit_display_start
  • bbcode_parse_start
  • postbit_imicons
  • bbcode_parse_complete_precache
  • bbcode_parse_complete
  • postbit_display_complete
  • memberaction_dropdown
  • tag_fetchbit_complete
  • forumrules
  • navbits
  • navbits_complete
  • build_navigation_data
  • build_navigation_array
  • check_navigation_permission
  • process_navigation_links_start
  • process_navigation_links_complete
  • set_navigation_menu_element
  • build_navigation_menudata
  • build_navigation_listdata
  • build_navigation_list
  • set_navigation_tab_main
  • set_navigation_tab_fallback
  • navigation_tab_complete
  • fb_like_button
  • showthread_complete
  • page_templates