www.webdeveloper.com
Results 1 to 3 of 3

Thread: Cannot update. Database or object is read-only.

  1. #1
    Join Date
    Mar 2003
    Posts
    43

    Cannot update. Database or object is read-only.

    Hi All,

    This is a question about connecting to a database and its problems.

    I have a friend who has just started developing and she is making a basic site for a company she works for. She has asked me to help her develop in ASP and this will involve connecting to a MS Access database.

    The problem is that the site is hosted on Active ISP. Whenever you try to update a record i a database you get the error:

    ##############

    Microsoft JET Database Engine error '80040e09'

    Cannot update. Database or object is read-only.

    /contactme/contactMeSubmit.asp, line 39

    ##############

    I figured this was a permissions issue as I got an error similar to this on mine and fixed it by giving permissions to everyone through the internet guest account.

    That said, her boss who uses - Dare I say it - 'Frontpage' told her to use frontpage along with the database wizard to create the site. When she uploaded to newly created pages along with the database, it worked and she was able to read and write to the database.

    I have never used Frontpage because I want to know how to program and gain knowledge not have some wizard do it for me.

    Looking at the code that frontpage generates, I haven't got a clue what is going on as it creates some kind of 'WebBot' system - which I believe is a frontpage extension??

    I really don't want her to have to use Frontpage to develop her websites as she will never learn the art of programming.

    Her boss is not prepared to ask Active ISP to enable permissions through the IUSR account so it looks like she is stuck with having to use frontpage for the interim.

    I Find it strange how frontpage can allow you to access and add/update a database but just using normal ado through ASP cannot.

    Am I presuming this is a permission problem by mistake?

    Can anybody help me out here?

    Many thanks

    Marko.

  2. #2
    Join Date
    May 2003
    Posts
    18
    hi,

    i experienced a similar problem when working with Access DB. it's absolutely a permissions problem and you were right reasoning that way.

    witold

  3. #3
    Join Date
    Jan 2003
    Location
    Jersey Girl
    Posts
    1,198
    hi Marko...

    check out this link:

    http://www.asp101.com/samples/index.asp

    they have database examples there.

    try to modify your db/pages to work with the code that they use.
    then... when you get it to work (and it will)...
    learn from that.

    and i admire your desire to learn without using WYSIWYG and wizards

    good for you!!!!

    k

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center



Recent Articles