That's exactly why it's too simple, the less code, the faster it loads. Besides, try testing it in any browser, I'm really eager to find one that doesn't work (so I can fix it).
Never heard about the DOM node called d
Whoops! I forgot to change that! The thing is that I point the document object to the variable d so the code size is smaller. So I'll replace it with document
Wrapped in "code" would be more appropriate.
I didn't say wrapping in "quote" was appropriate, just easier to read.